August 3rd, 2003, 16:16
how do I load the gui?

August 3rd, 2003, 17:37
To load it, run 'startx'. If you get errors, you are most likely running into a config error. If you do, run 'sysinstall' as root, and go to Configure>XFree86>xf86cfg --text-mode. Here you will be able to set all of your video config variables.

August 3rd, 2003, 17:41
Have you loaded X11 ?

If not cd in /usr/ports/X11/XFree86

then a make all install clean

after thats done type rehash then cd into your home dir and type the following:

XFree86 -configure

that'll generate a working X11 setup on your box then just copy you XF86Config.new file to /etc/X11/XF86Config,

then a startx should get you a basic gui.

Now you'll prolly want somesort of desktop interface like gnome or kde so once you have a base install of X working cd into /usr/ports/X11/kde3

and do a make all install clean

then followed by a rehash command and then cd into your home dir and type:

vi .xinitrc

add then following line

exec start-kde

save the file and you should be good to go, the next time you type a startx kde should load.

It should be said that I can't remember if the XFree86 port is XFree86 or XFree86-4 so maybe someone else could verify as I'm not on a FreeBSD box right now and I also can;t remember if the command in .xinitrc is startkde or start-kde, for the same reasons. I'm sure someone else will verify quickly though.

August 3rd, 2003, 20:18
yup, I installed pretty much everything for X11. I did what Kernel said and it loaded up, though my mouse was really squirelly.. don't know why.

August 3rd, 2003, 20:44
you need to configure moused.

You can do that through sysinstall by running


Then by going to the post setup configuration options and selecting the mouse menu. That'll be the easiest way for you.

August 3rd, 2003, 20:49
been there.. tried it several times.. is there any way to definitively tell that the config has been saved?

August 5th, 2003, 03:12
Might have to change your mouse protocol to "Auto" in XF86Config. That's what I did. Then I examined /var/log/XFree86.0.log and checked, just for curiosity, what protocol XFree finally used -- in my case, it was SysMouse. I'm not sure if I can go back and edit XF86Config so's it uses SysMouse instead. Works, don't wanna touch it :cool:

As to starting up X, you can modify /etc/ttys:

ttyv8 "/usr/X11R6/bin/xdm -nodaemon" xterm on secure

That is, if you're using xdm. If you're using gdm (or is it kdm??), there's another method I don't remember at the moment.

Regards, hope this helps.