August 24th, 2003, 14:51
HI all:
Odd problem here. I installed 4.8-RELEASE on a machine and then upgraded ports to CURRENT. After a portupgrade I started having problems with sound. I would boot into FBSD and sound would play and then after rebooting I would get no sound. I tried looking for error messages from XMMS or cdcontrol but it seems that as far as these apps are concerned everything is OK. I then tried changing some BIOS settings related to plug and play (saying no to plug and play OS). I rebooted and things seemed OK until the next reboot where I was again treated to no sound. This is pretty frustrating as everything seems configured properly (could be wrong on this . . . of course) but the darn card (an Ensoniq AudioPCI 1371) just does not want to work consistently. Any thoughts?

August 24th, 2003, 18:03
You might add these options for Ensoniq cards into your kernel if you haven't already:

[code:1:afb1fc446f]device sscape0 at isa? port 0x330 irq 9 drq 0
device sscape_mss0 at isa? port 0x534 irq 5 drq 1[/code:1:afb1fc446f]

August 26th, 2003, 19:07
Thanks for the feedback Killer. I tried to implement your suggestion but after I try to run config I get an error message complaining about there being no ISA devices (it's accurate, I don't have any). After fiddling around with the system BIOS though it seems (so far) that sound is now working consistently. I hope this holds up but I thank you again for your effort to help me out. :D

Former Member
August 26th, 2003, 19:53
Sounds as if u have onboard sound being activated via pnp...i think

August 26th, 2003, 20:10
Looks like that is likely the culprit. Even though this board (S1857 Trinity 371 w/BX chipset [I know, it's old]) does not have onboard sound, there is a setting in the BIOS that toggles onboard sound on or off. I did not notice it until I spent some time digging through the various BIOS settings. So far so good though . . .