August 26th, 2003, 08:28
hi all, new to the place after a night lurking. lovely place :) .


machin: compaq Armada 100s laptop
k6^2 500mhz :: 5gb hd :: 168mb RAM :: standard built in stuff

downloaded and burned the FBSD 5.1 iso's onto 80 minute CD-R's
1. my main machine see's and boots off the first cd np
2. laptop will not boot (won't even see) the first cd unless it has finished booting to windows
3. the bios has been updated to compaq's latest bios for the series and the boot order is set cd > floppy > hd
4. the laptop WILL boot from the 2nd cd, both cd's are the same brand

what i've tried:
1. tried making the boot/root disks and starting install from that
2. sysinstall doesn't see the cdrom
3. tried making a primary dos partition under win2k and copied the entire first cd 2 it in a FREEBSD labeled folder
4. choosing dos as an install media while using the boot/root disks to boot returns and error:
cannot see /dev/ad0s1 <blah blah blah sorry didn't write it down :( > /dist : no such file or directory
5. then tried copying all the 1st cd files and folders to the root of the dos partition and deleted the freebsd folder -- same thing

i don't have a nic for the laptop and the modem install would take for ever and i can't dedicate my mainline for that. any suggestions? thanks ahead of time :)

August 26th, 2003, 09:01
You can try booting off the floppy images?

on your cd somewhere probbibly in a tools folder or something is a kern.flp and oh damm whats the other one

(/me goes to their site to try to remember)

kern.flp and msroot.flp

Try some of the alternate methods in the handbook

let us know how it goes...

hugh nicks
August 26th, 2003, 13:07
remember you're going to need something like rawrite to copy the image to floppy. you wont be able to just dump the file on the disc and go.


August 26th, 2003, 15:19
i've already tried booting fro mthe floppies. booting from the floppies is the only way i've been able to get to the install screen...

its kern.flp and mfsroot.flp soup ;) .

anyone know a tried and true way of installing form a dos partition?

August 26th, 2003, 20:13
You've probably tried this but, the only way I can think of is via sysinstall. From the main menu choose Custom->Media->DOS. Though I don't know if this will work on Windows XP partitions since Windows XP might use NTFS or some other filesystem other than FAT32. About the only other option would be FTP install, but since you are on dial up that might be out of the question at worst you could do a mininstall via dial up and upgrade anything you need. Good luck, and let us know how it goes.

August 27th, 2003, 00:57
aye, i've tried to do an install through a dos partition. i created a 700mb primary dos partition and tried copying the install disk onto it. the install is looking for a /dist folder or something and not finding one...

hugh nicks
August 27th, 2003, 01:15
one thing you could try is re-burning your iso. something could have happened during the burn process for disc one. try to redo disc one, and burn it at a lower speed. might sound weird, but stranger things have happened. i know you said it worked on your main box, but i've had cd's work great on one machine, and gum up another. as i said, worth a shot.


August 27th, 2003, 09:43
Do you have one of them older type cd-roms that done like reading burned cd's ??

August 28th, 2003, 01:49
the kick in the head is...when an os is already reads the disk like a champ :/ . i just tried reburning the iso at 4x instead of 8x on a different brand cd-r...and it still didn't work! /cry

August 28th, 2003, 04:47
ok, here's the exact error message after selecting the dos install medium:

error mounting /dev/ad0s1 on /dist: no such file or directory (2)
^ this is my fat32 partition that has a c:\freebsd\base dir

any clues? X(

August 28th, 2003, 10:53
Here's a dumb question. Are you reading an ISO off the dos partition, or are you reading from the copied file system off the DOS partition? From your post I'd take a wild guess and say that you're reading off a directory you copied off the CD. Most GNU/Linux, *BSD installers try to mount the ISO image off the DOS partion and then install from there. The file which the installer looks for is something like 4.8-RELEASE-i386-disc1.iso, or whichever version you downloaded., once it finds it it mounts it and installs whatever packages you want. Hope that helped, good luck.

August 28th, 2003, 15:24
i'm using directories copied to cd then copied to disk from the iso. i haven't tried just copying the iso onto the hard disk...

August 28th, 2003, 16:18
Dump the iso to the DOS partition, that's what the installer wants. You can use something like dd (, and mkisofs (

August 31st, 2003, 03:43
Have you tried using the stable release, 4.8?

August 31st, 2003, 17:23
i haven't yet, its going to be the next thing i try once i get a chance to download it at home.