August 26th, 2003, 09:14
Ok.. Runing OpenBSD 3.3 and lately i've been having some problems with the ports tree.. It's the latest it gets cvsup'd every night via cron

if i go into we will use /usr/ports/games/cowsay for this example..

i go in there and issue the normal make install clean and i get this output.

===> Patching for cowsay-3.03
patch: unrecognized option `-z'
Usage: patch [options] [origfile [patchfile]] [+ [options] [origfile]]...
[-cCeEflnNRsStuv] [-b backup-ext] [-B backup-prefix] [-d directory]
[-D symbol] [-Fmax-fuzz] [-o out-file] [-p[strip-count]]
[-r rej-name] [-V {numbered,existing,simple}]
***> patch-cows_mech-and-cow did not apply cleanly
patch: unrecognized option `-z'

now this is no biggie.. took me a whole 5 minuites to figure out a way around this.. by changing the directory into the working directory patch it by hand and place a .patch_done file inside the ports tree.

Now when i return to the app tree i run make and all goes well. But once i goto install that puppie.. i get this output..

===> Building package for cowsay-3.03
pkg_create: illegal option -- S
usage: pkg_create [-Ohv] [-P dpkgs] [-C cpkgs] [-p prefix] [-f contents]
[-i iscript] [-k dscript] [-r rscript] [-t template]
[-X excludefile] [-D displayfile] [-m mtreefile]
-c comment -d description -f packlist pkg-name
===> Cleaning for cowsay-3.03
rm -f /usr/ports/packages/i386/all/cowsay-3.03.tgz
*** Error code 1

Stop in /usr/ports/games/cowsay (line 1715 of /usr/ports/infrastructure/mk/
*** Error code 1

Stop in /usr/ports/games/cowsay (line 527 of /usr/ports/infrastructure/mk/

Any suggestions? if not no big deal i was thinking about reloading it to 3.4 but i still would like to know the cause of this.. and it's not my shell's enviroment.. i've arlready tried changing shells...

August 26th, 2003, 09:47
I was having the same trouble with the ports. Less now that I grabed the releasse tree, but still some ports have trouble.

August 26th, 2003, 12:06
How are you cvs'ing your ports tree? The problem looks like you are trying to run -current ports on a -stable system. For example, the patch -z option is a new flag in -current but not in 3.3-stable. It's the same for the -S flag of pkg_create - it's in -current not in 3.3-stable.

Your problem looks to be that you are using different trees for different parts of the system, and that will break things.

August 26th, 2003, 12:55
thats what i'm assuming...

i now think i know where this issue came from..

When i first downloaded openbechede i ran it without defining a conf file for it.. and i decided to update the packages installed.. well it updated them all to snapshot and well not a single one would work anymore for odvious reasons.. so i spent that whole day reinstalling all the borked packages.. i'm assuming there's some i missed...

at any rate when i get home i'm gonna drop down to single user mode and update it to snapshot then do the packages.. hopefully that will take care of things... If not i have 'da floppy..