September 22nd, 2003, 23:15

I'm new here a friend recommended this sight to me he said that it's a great
place to ask for help on stuff without getting barbequed or flamed at like other message
forums full of trolls and grumpy people who are unfriendly/unhelpful
so giving this sight a try. I have been using OpenBSD 3.2 and OpenBSD 3.3
most recently but I've never setup a printer on it I was dual booting Win98 for
games and Quicken so I just ran my printer off Windows but now I'm ready to trash
Win98 and reclaim the 3gigs it's occupying and only run OpenBSD on my computer
soon I plan to buy a new computer with more space and have no plans to run Windows
on it either.

Ok here's what I've tried so far I downloaded cups (I'm open to alternative suggestions)

I compiled cups from source I downloaded cups 1.1.19 this compiled ok I could access
it from the web browser fine http://localhost:631

also downloaded gimp print I got a pre-tarball and compiled that with an ./configure with cups command the compile went fine next I accessed the cups configuration page
via netscape clicked on add printer new name etc. I browsed to the epson drivers and
found the gimp print one clicked on that. When I tried to run a test page though it
didn't print. I just want to get my printer up and running.

Thanks for any help


September 23rd, 2003, 11:54
You will need to check that the OpenBSD is detecting the printer properly. This is what I have always run into with CUPS. Although CUPS may have the driver, if OpenBSD doesn't see the printer as a device then CUPS cannot print to it. To check that the printer is a proper device, do a "dmesg" and check for the printer name listed. This will be important if you are connecting the printer via the parallel port, as the OpenBSD will not detect the printer automatically when just "plugged in" while the computer is on. For parallel connections you will need to have the printer on when the computer starts up so OpenBSD can detect and add the device. If you are using the USB connection, then it should detect it when it is plugged in, like normal USB. After turnning the printer on and pluging it in, do a "dmesg" to see if OpenBSD saw and added the printer as a device via USB.

You will also then need to choose the proper port when setting up the printer in CUPS. It should give you a choice of parallel or USB depending where the printer is. This should be a choice for you when you go through the "add printer" setup feature before you choose the printer driver.

Let me know if this helps, I'm sure that we can help you to get it working. I use CUPS at home with a number of local printers, including a epson color stylus 600 and a HP laserjet 5MP both via the parrellel port. So I know it can work.


September 26th, 2003, 12:06
Hi Krusty thanks for replying,

Yes my printer is connected via parallel port not USB. I did run a
few simple tests before I compiled cups and Gimp print.

lptest 20 10 > /dev/lpt0

OpenBSD could see the Printer and it was
able to print the test the so connection is fine

I need ESP ghost script for cups from looking at the dependency list on sight

I'm going to compile ESP and see what happens and try the suggestions
in your last message. Will get back to you guys :)